1. Hi everyone,

    Apple just released Logic Pro 10.5 for MacOS 10.15. We found out that Massive X, Crush Pack, Mod Pack, Replika, and Replika XT will crash.

    Our teams are currently working on a fix, and we hope to have this out to you as soon as we can!

    Best wishes, 
    The NI Team

    Dismiss Notice

Problem with number of multi outputs available

Discussion in 'BATTERY' started by xenon20, Oct 5, 2011.

  1. xenon20

    xenon20 New Member

    Messages:
    11
    Hi

    When I try to load a multi output version of battery 3 (in Logic 9 DAW) it gives me the options as shown in the first attachment.

    When loading a multi output version of Kontakt it gives me the options as shown in the second attachment.

    I have opened the instrument both in standalone and plugin mode to check the outputs section in the options window where both mono and stereo fields are set to 16.

    Does anybody have any idea why do I not have the ability to be able to load Battery 3 with the same output options as Kontakt, (i.e 16x Stereo outputs or 8x stereo, 8x Mono outputs?)

    I am using the latest version 3.2.3.

    Thanks

    Xenon20
     

    Attached Files:

  2. SloobyJane

    SloobyJane NI Product Owner

    Messages:
    232
    In Battery you set the output configuration in the Options screen. I run 16 channels into Cubase with no problems.

    In Cubase, I have to select the output channels coming from Battery. By looking at your screen shot it appears that you have only opened up a total of 14 channels in Battery. I think the first 2 are always set as master stereo out. I'm not sure of the maximum nuber of channels from Battery but I have 18 open, (1) stereo out and (16) mono set in the options.
     
  3. xenon20

    xenon20 New Member

    Messages:
    11
    To confirm, I have done this.

    Which options are you refering to in Cubase? I am using Logic 9 and can't find any options to select the number of output channels coming from Battery.

    Your advice is appreciated.

    Xenon
     
  4. Houseghost

    Houseghost NI Product Owner

    Messages:
    109
    Please post a screenshot of your routing setup inside battery.
     
  5. Ruari

    Ruari NI Product Owner

    Messages:
    265
  6. xenon20

    xenon20 New Member

    Messages:
    11
    Hi

    here is that screenshot...

    Ruari, my problem is exactly the same as yours BUT I found the problem 3 days ago when using the older version (don't know what version I was on before), so I updated hoping that it would resolve my issues to no avail.

    I think I will also try rolling back to 3.2.2 if your saying the problem does not exist for you. What is the preferred method of reverting to a previous version please?

    Thanks

    Xenon
     

    Attached Files:

  7. xenon20

    xenon20 New Member

    Messages:
    11
    also I don't think I have the 3.2.2 download on my computer anymore. Is it stored somewhere as a backup? If not, how do I obtain it ?

    Thanks

    Xenon
     
  8. Ruari

    Ruari NI Product Owner

    Messages:
    265
    Are you on a Mac? If you use Time Machine you might be able to go back through your files to get the 3.2.2 update. If not see if you are still able to download it from here, if you can just run the installer & you will be fine.
     
  9. presence

    presence Forum Member

    Messages:
    60
    Hey I just wanted to let you guys know that I'm getting the correct output selections (16xstereo) with Battery 3.2.3 and Logic pro 9.1.5. So maybe something else is going on in the equation other than Battery 3.2.3.
     
  10. xenon20

    xenon20 New Member

    Messages:
    11
    Thanks presence for letting us know that. After reverting to v3.2.2 I have the correct output configurations under the battery 3 heading (as shown in my kontakt screenshot above) but I am also using Novations automap software (for midi controller)which creates an automap wrapper for NI plugs. I am still getting the wrong configrations under the automap heading.

    Ruari, are you using automap software at all?
     
  11. rbh

    rbh Forum Member

    Messages:
    55
    I don't know if this applies to the question.... but I believe that when battery was upgraded to version 3.0.4 that the outputs option got sort of hardwired to having to use all 32 outputs, which I think gets configured to 16 stereo outputs. I don't know for sure but it may be worth a look at the version info files.
     
  12. Ruari

    Ruari NI Product Owner

    Messages:
    265
    My output issue was solved by opening Battery standalone, opening the options & selecting 1 stereo & 32 mono outs.

    I closed Battery then opened it up as an AU in Logic then shut it down again, re-opened Battery standalone then chose 16 stereo & 0 mono in the options.

    As before I closed it, then opened it as an AU in Logic & somehow I now have the 16 stereo outs option available to me.

    How that made a difference is anyones guess, but it worked for me…