1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Save Instrument from K5, not K6

Discussion in 'KONTAKT' started by Arthur Neeman, Oct 3, 2019.

  1. Arthur Neeman

    Arthur Neeman New Member

    Messages:
    9
    Hello, wise people! :)
    This June I had upgraded to Komplete 12 Ultimate CE and have Kontakt 6. Many times I read that it is good to save NI instrument with Kontakt 5 because not all upgraded to newest Kontakt and could not open instruments saved from 6th version. So from where I can download 5th version? In downloads I see only Kontakt 5 player, not full version.
     
  2. DarkStar

    DarkStar NI Product Owner

    Messages:
    2,051
    What did you upgrade from? Perhaps you had Kontakt 5 previously? Otherwise, the only way to get it would be by Transfer from someone who no longer needs it.
     
  3. Arthur Neeman

    Arthur Neeman New Member

    Messages:
    9
    I had Kontakt 5 player and all other free stuff. Then last year I start to buying step by step from SELECT to ULTIMATE and now have whole Universe from NI :) But for full happiness I would like to save my instruments for version 5 and I cannot do that with Kontakt 5 player. Save needs full version.
     
  4. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    You should be able to see Kontakt 5 in your NI account, and if you don't have it installed on your computer, it should be under Not Installed section in Native Access.
     
  5. Arthur Neeman

    Arthur Neeman New Member

    Messages:
    9
    No. It isn't there.
    I open Native Access and in a whole list of Komplete 12 I have Kontakt Player 5 and right column tells that it is DEMO. No Kontakt 5 with FULL VERSION. And My Account on NI site doesn't contain anything for Kontakt 5.

    Am I right that I simply should install it and it will work because I have Kontakt 6 full version? If yes, then from where to download it? I don't want to click on unauthorised links in google search ;)
     
  6. MarioD

    MarioD NI Product Owner

    Messages:
    304
    FYI - I have a lot of third party software as well as NI software that I purchased while using Kontakt 3, 4 and 5. Everything works perfectly with Kontakt 6. Kontakt is not backward compatible, that is saved or purchased Kontakt 6 instruments will not work in Kontakt 5, but it always has been upward compatible.

    The only need for both 5 & 6 is if you have songs using version 5 sounds. Without 5 you would have to redo these songs with 6. That is not a big problem here but YMMV.
     
  7. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    The other way around. Kontakt has always been backwards compatible (which means newer version can load older version files), but it's never been forwards compatible (which means older versions can load newer version files). Google it. ;)
     
  8. MarioD

    MarioD NI Product Owner

    Messages:
    304
    Yes, I did explain it right but my terminology was wrong. Sorry for any confusion that I may have caused.
     
  9. Arthur Neeman

    Arthur Neeman New Member

    Messages:
    9
    But you cannot give away an instrument created with K6 if many users still using K5. That's why I need K5.
     
  10. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    If you only had K5 Player then you'd need to upgrade it to full version. However NI is not doing these upgrades anymore so you would have to find a second hand license from someone.

    Also K6 already had a very good conversion rate of people upgrading from K5. I don't think you need to worry much.
     
  11. Arthur Neeman

    Arthur Neeman New Member

    Messages:
    9
    Yes, I don't worry about myself and my workflow. I'm worried about others who cannot upgrade to K6, but needs instruments for their K5. In every discussion I see that people still using K5. Of course I'm happy with K6 and creating my own sample libraries was reason why I upgrade from SELECT to the higher level (and full Symphony Series was another reason to upgrade to Collectors Edition).

    About technical nuanses I know all - versions and back/forward compatibility. I was searching for K5 just for widening my workflow to make some other people happy :)

    How the big manufacturers do? All their instruments are for K5. Of course they have K5 for some 10 years since they're in business. Audiobro, Heavyocity, Spitfire, Sonuscore... So I just want to download and install. It's the same simple as I asked in Steinberg forum for Cubase 5 (for my mobile rig with stone-age laptop running WinXP) last year and they gave me a link. Do you want to tell me that NI deleted all copies of K5? :D
     
    Last edited: Oct 4, 2019
  12. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    They didn't delete them but they don't make them available for sale anymore. You can still get it, but you just have the free player, not the full version, so you need a license to activate the full version. This is what you'd need to buy second-hand.
     
  13. Arthur Neeman

    Arthur Neeman New Member

    Messages:
    9
    Hmm, strange! Having K6 licence I need K5 licence to use it? Do you upgraded from K5 to K6 for full price as if buying full version without upgrading? I think that K6 includes all the features of K5 and is the descendant of K5, therefore K6 licence should cover K5 licence, IMHO of course.

    What I should say to customer if he cannot open my sample library? "Please upgrade to K6"? :)
     
  14. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    It doesn't work like that, not just with NI but with many other software companies. Major versions of products have separate licenses, they don't include licenses for previous major versions of it. This is pretty normal.

    If you want to cover your bases, you need a K5 license and make your libraries in K5 then. That's all there's to it.
     
  15. DarkStar

    DarkStar NI Product Owner

    Messages:
    2,051
    Think of K6 and K5 as different programs that happen to have very similar functionality and appearance.
     
  16. Arthur Neeman

    Arthur Neeman New Member

    Messages:
    9
    I somehow disagree with you because when you upgrade from K5 to K6, you won't pay the full price of K6. This proves that K6 is descendant of K5. De Facto! Of course the company's politics can differ from other companies, but this puts me in a nervous situation - why I should pay for old software if I already have newest one, but it cannot save instrument in older format to be compatible with other people needs? Maybe NI can disable all uses of K5? That will be more friendly for users of K6 who create instruments ;) :D
     
  17. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    15,186
    You may disagree but that's all. This is how things work with NI, and many other software vendors. Latest version license doesn't automatically grant you licenses for all older versions.

    Saving instruments in older version formats is full of all sorts of caveats depending on which actual features of Kontakt are used, as those did change throughout the years, and this results in a huge amount of possible combinations where things can go horribly wrong, which is why NI doesn't implement the option to save as older Kontakt version. Don't expect this to happen, ever. If you want to do K5 libraries, you need to have a K5 license, period.
     
  18. Arthur Neeman

    Arthur Neeman New Member

    Messages:
    9
    Clear. Period.