Some Bizarre Behavior this morning.

Discussion in 'TRAKTOR SCRATCH' started by FunkyRob, Apr 24, 2007.

Thread Status:
Not open for further replies.
  1. FunkyRob

    FunkyRob Forum Member

    Messages:
    87
    I got TS installed last night and didn't get to play with it this morning for about an hour.

    I got a mac powerbook G4 1.67 Mhz with 2 GB RAM.

    I've registered and installed an update (don't have it with me, I'm at work shhhh!) I forget what version number.

    started with all the default settings but changed the audio to 44.1.

    I loaded my favorite electro track; Al-Naafiysh by Hashim on both decks A & B and proceeded to play around with it.

    Response was pretty good, but sometimes the audio would sound kind of 'garbled'

    I paused for about a minute or so and when I came back, deck A started to play at a higher speed. I thought I accidentally hit the '45' button on my turntable so I looked down and that wasn't the case. It was doing it on it's own.

    I tried to re-calibrate and then deck A wouldn't finish calibrating.

    Quit TS and restarted and the same thing on deck A - wouldn't finish calibrating. I did all the obvious, disconnect/reconnect, clean the needle, etc, and still wouldn't finish. The funny thing, even though it gave me a message up there saying that it was going to only use absolute mode, it would still allow vinyl control to some extent. It sounded like hell, but I still got some reponse when I moved the record back and forth.

    Also noticed when deck A was stopped, and I was scratching on only deck B, it was showing some activity on deck A like I was adjusting the pitch on deck A or something.

    I was connected to my brand new Numark DXM09 mixer that I bought at guitar center the same time I got TS. when I go home tonight I will try my old cheap & trusty Numark DM1002mkII and see if I have the same issue.

    Thinking about posting a video on youtube or something to try and explain it better.
     
  2. sergeramirez

    sergeramirez NI Product Owner

    Messages:
    167
    Same thing happened to me, I have the same Mac, same Ram, it sounds with a delay, usually happens when you are connected to the net or with the browser open, CPU meter also fluctuates like the Master Meter. Wont let you calibrate. Seems to be a PowerBook issue.

    Does the "search" seem to take a little longer than on T3? When I search for an artist 2 or 3 titles show up first, then the rest of the titles come after.
     
  3. FunkyRob

    FunkyRob Forum Member

    Messages:
    87
    OK something I just discovered. When I went into setting and changed the audio device to the Audio 8 DJ I also changed the sample rate to 44100 (I didn't think I could tell a difference.) besides when I record my wax collection to mp3, I have it set to 44100 anyway. What I DIDN'T change was the audio latency. It said 2.0 ms so I left it.

    Came back to this afternoon and the same stuff. I tried all the usual and nothing. The calibration kept jumping like crazy and it would say unknown medium and never finish.

    I went back in the audio setting and for the hell of it went to audio latency. What I noticed was it still said 2.0, but when I went to change it I noticed 2.0 wasn't in the list of what to change to. It seems that the choices of latency changes if you change the sample rate. So I picked 2.5 because it was on the list and it seems to be sounding perfectly now.

    I went back in to see if it would let me re-create it to the way it was this morning and it won't do it anymore. Now if I change the sample rate the latency changes with it automatically. For some reason the first time I changed it, that didn't happen......weird....

    What I am noticing now though is even though it sounds nice, the calibration still looks a little out of wack. I looks just like the "Example of bad Control Signal" picture on page 24 of the manual. I am not getting the picture on page 23.

    No I just noticed......I took the needles off the timecode records to write this. Went back to put the needles on and calibration never notices that I put the records back on.

    Oh and to answer your questions. Yes searching is slower and the CPU meter LED at the top of the screen is just wiggling back and forth, even when I'm not doing anything.
     
  4. FunkyRob

    FunkyRob Forum Member

    Messages:
    87
    OK, another issue.

    I had a loop playing on deck b. I had a quick drop in the audio while I was loading another track on deck a.

    Still getting some sound quality issues too. Not as bad as earlier, but kind of comes and goes.
     
  5. FunkyRob

    FunkyRob Forum Member

    Messages:
    87
    Update.........


    OK, so I did some basic mixing for about 45 minutes or so and I can honestly say that as is, this is not gigable (is that even a word) for me right now.

    numerous clicks, a few weird buzz noises, sound drops etc. I'm suddenly not so eager to sell my FS2 on ebay just yet.

    I guess there's still some issues with Mac G4's?

    Since it's not even supposed to be out yet I guess I can't really complain. come May 1st, I will be b*tch*ng like crazy if this isn't fixed. :p
     
  6. DJ Freshfluke

    DJ Freshfluke Traktor Mod Moderator

    Messages:
    26,765
    besides the fact that NI is working on the powerbook issues....

    dont you think that a latency of 2 or 2.5 is really a bit low for a computer that is at the lower end of the specs?

    have you tried to raise the latency to let's say, 6?
    and how are your cache settings?
    key lock on?

    and most definitely i would recommend you to deactivate the airport and every other internet related stuff when spinning...

    there are some hints on optimization for macs at the end of the manual and some more on the NI website!
     
  7. FunkyRob

    FunkyRob Forum Member

    Messages:
    87


    Good Points. Funny seems like it wasn't that long ago this $2000 powerbook was 'Top Of The Line'. Also I kinda thought that 2GB of RAM would kind of make up for it.

    Disabled all the stuff mentioned in the back of the manual....I'm gonna miss that really cool itunes artwork screensaver :( I disabled that dashboard crap a long time ago. Who really needs those stupid widget things anyway.

    I upped the latency to 5.5 (6 wasn't a choice) and I got a world of difference in sound quality. Cache settings are whatever the default is, I haven't messed with it yet. And I hardly ever touch the keylock. I guess you can adjust that too? I haven't gotten that far yet. I need to take a vacation and lock myself up in a room for a week with this.

    How long is a ms anyway? What was the min in TFS2? What's it in SSL?
     
  8. theXinok

    theXinok New Member

    Messages:
    13
    A ms is a millisecond, or a thousandth of a second (0.001).
     
  9. DJ Freshfluke

    DJ Freshfluke Traktor Mod Moderator

    Messages:
    26,765
    there are several ways to calculate the overall latency in a system, therefore i dont want to say anything about it.

    btw, it's not the only thing that helps getting a feeling of *tightness*.

    i'm glad, the tweaks helped you!
     
  10. BigBuddha

    BigBuddha Account Suspended

    Messages:
    286
    Excuse me but this is kinda arrogant. IMHO TS shoold work without any problems on G4 PB from last generation.
     
  11. nohiphop

    nohiphop NI Product Owner

    Messages:
    943
    I would agree to you when talking about Problems in normal functionality, but setting latency to 6 ms is something that seems acceptable to me. I used 6 ms with Traktor 3 / FS and it felt ok for me.
     
  12. BigBuddha

    BigBuddha Account Suspended

    Messages:
    286
    I think if audio8 got this minor latency u should be able to use it also on a G4 PB. I mean e.g. Final Scratch runs without any problems on a much slower 12" PB!! When I read such a comment from native_girl which probably is related to NI I really feel upset. Such a comment is very very mean and to repeat myself absolutely arrogant. NI should do their homwork and develop good drivers working for an PB G4 which is not at all a computer from the beginning of the last century - in fact they spit out arrogant (again) comments, do very good advertising until you buy one product and then they will leave you alone. Poor.

    Just my 2 Cents.
     
  13. PhilL

    PhilL Moderator Moderator

    Messages:
    7,084
    Couple of things. First off I understand those who are running powerbooks are p!ssed off, but please lets not turn this into yet another p!ssing match.

    G4 performance is lacking and it needs further optimizations to get it working well. The first update helped but it did not solve all problems as was hoped. We need to hear from everyone who runs a G4 who is having TS performance problems as well as those that don't so NI can get a clear understanding of the breadth of the issue. My take is that are more G4 users around that want and do try to use Scratch but who see problems.

    If it turns into yet another cat-fight figer / pointing session, some/many G4 users who do have issues will be dis-inclined to post, so the scope won't be properly shown. Its a given that performance is not where it should be for affected G4 users. Its also given that something needs to be done about and we know who that somebody is. What needs to be clarified is the current scope of the problem within the user community. To do that we need to hear from all G4 Scratch users both those that have probelms and those that don't.

    Remember too if its a truly intolerable situation for you, it is possible for you to return your Traktor Scratch product for refund. If you decide that road is the one you'll go down and need help then please email me and I'll help as I can.

    Phil
     
  14. *FSuser*

    *FSuser* Forum Member

    Messages:
    83
    I am sorry for the above users who are experiencing this issue after spending money on this product. I myself bought into the NI hype and have felt the burn...

    So just like Microsoft NI has no problem releasing a sub-standard and non-tested product as long as they appear to be fixing the problem via "patches" and or "updates". =(

    The G4 PowerBooks with the problems are far from being sub-par when it comes to current CPU power, however I do not feel that the CPU is the problem. I would assume that TS has been optimized for Universal Binary and the IBM CPU's were left out to dry when it came down to testing.

    PLEASE ALL G4 USERS POST YOUR PROBLEMS WITH THE TRAKTOR SCRATCH PRODUCT!... AS IT WILL HELP NI FIX THINGS! PLEASE DONT BE SHY AND POST YOUR PROBLEMS... THERE WILL BE ABSOLUTELY NO FINGER POINTING WHEN IT COMES DOWN to IT!


    In closing I must post your first statement as my last since I found it the most humerous. Take a look at the posts you have made recently towards myself and others and ask yourself who really wants a "p!issing" match.

     
  15. djeidolon

    djeidolon Forum Member

    Messages:
    126
    I'm surprised NI is even supporting the PowerPC architecture still. I wouldn't. :)
     
  16. PhilL

    PhilL Moderator Moderator

    Messages:
    7,084
    There is still a pretty decent sized community on Powerbooks and its likely to be later next year before it really diminishes substantially in size.

    I think dropping support for powerPC processors would be a pretty unpopular move.

    Phil
     
  17. *FSuser*

    *FSuser* Forum Member

    Messages:
    83
    Interesting... I think the final scratch DVS solution I paid for also had a decent sized community as well. I would even guess that the PowerBooks mentioned were purchased in a simliar timeframe.
     
  18. PhilL

    PhilL Moderator Moderator

    Messages:
    7,084
    I believe the current issue is largely unaffected by latency, it improves a little at higher latency but does not go away altogether.

    Phil
     
  19. BigBuddha

    BigBuddha Account Suspended

    Messages:
    286
    To be honest it doesn't affect me if it is latency or dull programm code. TS should be work proper on G4 PB but it doesn't. You should be able to focus on music and use computer and software as tools.
     
  20. BigBuddha

    BigBuddha Account Suspended

    Messages:
    286
    BTW Where is the update?
     
Thread Status:
Not open for further replies.