1. Hi everyone,

    This forum is now closed for posting! If you require technical support from NI or have a questions about activating your product, please head over to our new Support Community!

    NATIVE INSTRUMENT SUPPORT COMMUNITY

    The Support Community is the new location where you can expect to receive assistance and feedback on technical support, sales or installation issues from our Support Agents and other users.

    Please also note, questions about the status of an order should always be directly sent to our Order Support team HERE.

    Best wishes, 
    The NI Team

Sound drop outs under Yosemite

Discussion in 'Technical Issues (Archive)' started by DJ Tomixxx, Mar 21, 2015.

  1. ReeceDuncan

    ReeceDuncan Member

    Messages:
    47
    So what they're saying is, we don't know how to deal with it, even though Serato have managed too! Washing their hands of the issue!
     
  2. djgr

    djgr New Member

    Messages:
    11
    Currently I am escalating this issue to apple, they have no recollection of the issue being logged by N.I. however they are being incredibly helpful at the current time. I would suggest as many people lodge this issue with apple directly and raising the issue. the more voices, the more likely they respond and solve things on their end.
     
    • Like Like x 1
  3. frankle

    frankle NI Product Owner

    Messages:
    738
  4. Dj Max-Matic

    Dj Max-Matic Forum Member

    Messages:
    442
    Ive reverted back to mountain lion, ill keep everyone posted on whether or not thats a successful option. The reason I say this is because if you use migration assistant to copy your data back onto your mac ( like i did ) i belive some files and data from either mavericks or yosemite ( whatever you are running) are copied back to the system.
     
  5. djenzyme

    djenzyme NI Product Owner

    Messages:
    540
    The latest Serato update has made the dropout issue much less frequent, although it does still exist. At least they are trying

    I'm a bit confused over this issue. Is the dropouts issue the same as the mega latency issue? Seems like it is, but obviously many that are getting dropouts aren't using timecode at all.

    If Apple can address this issue then that would be great but N.I. should be looking at working around this problem for now. Either that or at least reinstating support for Mountain Lion with the latest Traktor releases.
     
  6. Dj Max-Matic

    Dj Max-Matic Forum Member

    Messages:
    442
    you cant reinstate support that wasnt there in the first place lol....im just sayin
     
  7. djenzyme

    djenzyme NI Product Owner

    Messages:
    540
    Yes I didn't word that very well. I think you get the general idea though :oops:
     
    • Like Like x 1
  8. blakis

    blakis New Member

    Messages:
    29
  9. frankle

    frankle NI Product Owner

    Messages:
    738
    I'm in the same situation as most having the issue, I DJ several nights each week and have invested plenty of money and time into Traktor and don't really want to start fresh with other software. I currently take a pair of D2's into venues that I work in so that I end up with 4 screens of control by using them with the installed CDJ2000NXS players. I don't specifically use Stems or even Remix Decks but having the screens and access to 8 hot cues (yes I've remapped the CDJ's to do all 8) and loops across all 4 decks suits the way I play. Using the soundcard in the venues installed DJM850/900NXS is the quickest way to get audio playing, but I've had more issues with these mixers than any other soundcard (and they really don't sound that flash either). I've also had the same issue with an A&H DB2 but when I had my older MacBook Air (USB2) I was part of beta testing and they seemed to be able to solve the issue. Moving to my newer MacBook Air (USB3) and there were other issues with the DB2 and so I stopped using it, and moved to my TA10mk2 and TA6, but these also faulted on me and so I went back to plugging into the in-house mixer, and had the issue return intermittently. I had an opportunity to test an RME Fireface 802, and this worked flawlessly for the 2 weeks that I was able to try it out. After this I went back to using the in-house mixers and funnily enough I didn't see the pause/stutter/audio drop issue return for about 2 months! It has now returned, and although I don't have it every gig it's always in the back of my mind.

    So, I need to have a reliable system, and so does everyone here in fact. With this in mind, who has a reliable system that doesn't suffer from this issue:

    @TroyMichael - your signature says that you're using 10.8.5 and 2.6.8 ... Are you getting the dropout issue with this combination?

    Is there anyone using OS X 10.8.5 and either Traktor Pro 2.8.x or 2.9.0? I know that there are "issues" with this that NI have put in the notes, but is anyone experiencing these or is NI trying to just "move on" from this older OS and not have to support it?

    If I can get a positive answer then I guess I'm lucky that my MacBook had an original install of 10.8.4 and so I can actually roll back with my 10.8.5 USB installer. I'll do a full bootable external backup of my existing install (I'm not a fan of Time Machine), and then go for a clean install of (probably) Traktor Pro 2.6.8. Unfortunately it'll mean going back to my pair of X1mk2's instead of my pair of D2's ... Lucky I haven't gotten rid of them yet!
     
  10. Dj Max-Matic

    Dj Max-Matic Forum Member

    Messages:
    442

    Im currently testing with 2.6.8 on mountain lion 10.8.5. This was my last known stable config prior to the mavericks update. I just recently re-instated this config so I will keep everyone posted. I want a decent sample size of data before I advise on the stability.
     
  11. TroyMichael

    TroyMichael Forum Member

    Messages:
    1,279
    I have several macbooks that i use but my main setup is 2.6.8 on on10.8.5 I have not had any dropouts with this setup.

    I have have seen the issue while testing 2.9 with 10.10.5. on a different MBA. I notice it occurred only when it was hooked up to a S4 MK2 vs No Controllers. I do a lot of testing with just the laptop with music playing out of its speakers.

    I also noticed it happens only when you have 2 more more decks playing. I have never had it happen when only one deck was playing. I also used 2.6.8 with 10.10.5 and did not have the issue but note that my usage with this combo was minimum so i can't say for sure.

    The biggest problem with this is not the problem itself...but the way NI handles it. Even if its is an apple issue NI has done little to nothing to help its customers.

    Here is a good example of where NI could better communicate with the community. This is a major issue that impacts a lot of users. It sad that the moderators or other from NI do not provide added info on this issue. We are left hanging.

    It reminds of the Freeze issue when the S4MK2 first came out. NI blamed apple and for a long time did nothing. This for me was when i started losing faith in NI. Prior to the S4 Freeze issue i was a Huge NI fan Pre ordering everything they put out. The issue with the S4 was later resolved with a firmware to the S4 so not sure it it really was an apple issue like NI claimed but it took NI a long time to resolve it.

    I been using serato more lately as i feel traktor is a sinking ship. I have had no issues with drop out on serato but that was also with 10.8.5
     
  12. DJ Tomixxx

    DJ Tomixxx New Member

    Messages:
    24
    Hey all,

    Serato support tries everything to solve the issue at the moment. Therefore it is important that we all use an indentical OSX setup allowing us to comapare. I would suggest to optimize your MacBook before reporting this issue. Make sure energy saving options, wireless communication, and sportlight indexing are off. Furthermore, reboot your Mac before testing. It all my help.

    Serato recently updated their Mac optimization guide, see https://support.serato.com/hc/en-us/articles/202833544-Mac-Optimization-Guide-for-OS-X. In particular, MacBooks have a "Sudden Motion Sensor (SMS)" preventing your hard disk drive from damage in case of sudden motions. A Serato support guy claims that this sensor might be kicking and cause the drop out. You can disable this sensor using the terminal console:

    sudo pmset -a sms 0
    Press Return (typing in ’0′ disables it, '1' will enable it).

    Does disabling the SMS solve the issue?

    If disabling the SMS does not help, then Traktor has never been ready for Yosemite and Mavericks.
     
  13. Dj Max-Matic

    Dj Max-Matic Forum Member

    Messages:
    442
    I dont think its the sensor personally, I never had to even change my energy settings when Traktor was operating smoothly. Ever since the mvericks update I have had a continuous loss of time code signal and random dropouts combined with high load on the load meter. when the drop outs and loss of time code signal occur, my aA10 interface flashes on and off showing either input or no input. I believe it to be an issue with either the core audio driver, traktors driver, or the firm ware on my A10. Firm ware is up to date according to device updater, is there a way to roll back to try other versions of firm ware for my interface?
     
  14. TroyMichael

    TroyMichael Forum Member

    Messages:
    1,279
    I did a small amount of testing... which may not mean much. I did a 2 different 2 hour test set with 2.6.8 on Yosemite. No Drop outs. When tested 2.9 on Yosemite i got drop out about one every 2 hours. My initial feeling was this was a 2.9 related issue. but from what others have posted this is probably not the case.

    I also tested the latest version of serato on yosemite on 2 different 2 hour test test. No drop outs.

    My test on traktor were done with a S4MK2 and on serato with a Pioneer SX.
     
  15. Dj Max-Matic

    Dj Max-Matic Forum Member

    Messages:
    442
    to follow up, i have seen some improvement on mountain lion and 2.6.8 but not a complete solution. I still get high loads and sudden pops and clicks despite running a high latency setting ( higher than my original setting of 44,1000 and 576 . testing has occured over 4-6 seperate sets. symptoms occur approx 30-40 min into the set. after symptoms show, restart or shut down does not offer any immediate relief. Please keep in mind i did use migration assistant to copy over apps and docs after reverting back to mountain lion, so not a clean install of only mountain lion I supposse. I am also running other audio programs on my machine, but not while using traktor. I have pro tools, reason, and abelton on my comp ( just for an fyi).
     
  16. djgr

    djgr New Member

    Messages:
    11
    As things stand, after conversing with Apple Support and being referred to a senior Engineer, it has been confirmed that there is a bug. They have promised that they are working on a patch to fix the problem, but as this problem has been around since Mavericks and were getting close to the release of El Capitain, I certainly won't be holding my breath for any sort of solution any time soon.

    Basically, nothing can be done so anyone on a mac is basically stuck with 2.6.8 and mountain lion and can't proceed any further, no updates, new features or any level of stability. Of course you could completely defy the point of buying a mac and dual boot with windows.

    Happy days!
     
  17. TroyMichael

    TroyMichael Forum Member

    Messages:
    1,279
    I did more testing and put about 10 hours of DJ time on 2.6.8 with 10.10.5 not one drop out.

    it my case it appears the drop out issue is either only on 2.9 or happens more frequent on 2.9 When i ran 2.9 i would get drops out issues on average every 2 to 3 hours.

    Has anyone had drop out issues on 2.6.8 with 10.10.5?
     
  18. DJ LISTS

    DJ LISTS Forum Member

    Messages:
    92
    I fear that there are multiple issues going on here. What I have experienced is a single audio dropout, lasting maybe 4-5 seconds, with the waveform hesitating for about 1 second in the middle of that 4-5 second window. After that Traktor continues to run normally. I get usually one such event in a 3-4 hour gig but not always.

    Both my MBP's are Yosemite with Traktor 2.6.8. The laptops behaved fine on 2.6.8 and only recently started with the random audio dropout. Since the laptops are kept clean and only used for DJing, an OS upgrade is the most likely culprit.

    Others are reporting stuttering, crackling, and latency issues. I don't see any of that. What I see is about the same thing that happens when I quickly power-cycle my controller. This seems to support the theory that core audio is randomly resetting.
     
  19. frankle

    frankle NI Product Owner

    Messages:
    738
    There are 2 current issues in this thread:

    - audio dropout / pause / stutter happening at random intervals - this can be confirmed by checking your Console Log and finding reference to "IOAudioStream" at the time of your drop out. This is what was originally posted about and is what the thread should continue to be about. This is the issue that I have been having.

    - mega-latency issue while using time code - also known to happen in Serato, here is one such thread about it and one of the more recent people affected was @Karlos Santos ... Which does not seem to have any Console Log entries associated with it:
    https://www.native-instruments.com/...ssue-with-2-8-scratch-cannot-trust-it.257722/
    This issue should probably be followed through on that thread and not this one.

    Personally I have rolled my system back to 10.8.5 and Traktor Pro 2.6.8 between last Friday and Saturday's gigs. I have installed only Traktor, Pioneer DJM850 & 900NXS drivers and Mixed In Key. I have not signed into any extra "Apple Sevices" like iCloud, I have changed all of the "energy saver" settings, I have changed "software update" to never check, I have disabled every "notification", I have turned off the screen saver. I am not updating anything OS related including iTunes 11.0.4 that it comes with as a fresh install.

    I transferred 70GB of music from my bootable external Thunderbolt SSD copy of my 10.9.5 install (took no time at all mind you), and then started Traktor and added folders to my collection using the ASYNC function. I had time to do around 40% of that music before going to my gig. I then added the rest of the music to the collection without analysis, and if I happen to need one of those tracks it was analysed upon loading.

    Other Traktor settings, 512 latency (I used to use 256 but whatever), 48k, multi core enabled. DJM850 as soundcard via the left USB port, right USB connected to the DUB-7H powered USB hub, then this to a pair of CDJ2000NXS, a pair of X1mk2 and an F1.

    For the first part of my gig I saw the load meter bouncing up and down quite a bit in Traktor although it seemed to be fairly consistent around 40% in Activity Monitor.

    No audio dropouts and no Console entries for IOAudioStream in a 5 hour gig. I have another 2 gigs this weekend and will report back after them.
     
    • Like Like x 1
  20. blakis

    blakis New Member

    Messages:
    29

Share This Page