Solved Traktor Pro 3, iTunes, AIFF, and ID3 tags

Discussion in 'TRAKTOR PRO / TRAKTOR SCRATCH PRO' started by Terry Ferg, Feb 20, 2019.

  1. Terry Ferg

    Terry Ferg New Member

    Messages:
    21
    Wondering if anyone has had this issue.

    I do library management in iTunes, since TP3 lacks heavily here.

    I use AIFF because of ID3 tags and prefer to keep tracks at full quality. I’ve never had problems (over 5+ years).

    I recently changed the comments on all my songs in iTunes. All songs display the ID3 tags and artwork in iTunes and even in external tag editors.

    All songs are ID3 version 2.4.0, and clicking convert in iTunes everything is greyed out except create AIFF version.

    I’ve done a fresh install of Traktor Pro 3 and here’s what’s happening:
    1. When adding to collection a handful of tracks are fine. All my new tags are there and Grid + Cuepoints are there.
    2. Most of The other tracks when adding to collection I get an error “ID3-tags can not be read on...”
    3. All my new tags are there but none of my Traktor data - grids, cuepoints, etc. and no Artwork.

    Things I’ve tried:
    1. Check consistency in Traktor
    2. Checked permissions on the whole directory structure and I have read and write privileges.

    Additionally:
    1. In iTunes if I select a track and go to File > Convert > Create AIFF (which is the only option not greyed out)
    2. It creates a new file, still in ID3 v2.4, and the only changes I see is to the file name.
    3. When I add this new file to Traktor Pro 3 collection, there is no error, and Artwork is there... but all Traktor related info is gone.

    So it appears there is some issue with ID3 tags in the original file, although I can’t figure out what it is.

    Wondering if there is anyway or app to fix this - or anyway to force iTunes to re-update ID3 stuff or version?

    Otherwise I guess I need to re-convert these in iTunes (to the same format, which doesn’t make sense) and redo all grids, cuepoints etc.
     
    Last edited: Feb 20, 2019
  2. WandaMayer

    WandaMayer New Member

    Messages:
    11
    When i read this i get scared to update to 3.x ... I'm still on Traktor 2.11.3
    Did this improve with the newly released 3.1? Even though it's not recommenced to update from what i read in the forums — crashing a lot.

    NI, what's going on? It seems version 3 was not really ready for prime time.
     
  3. Terry Ferg

    Terry Ferg New Member

    Messages:
    21

    This isn’t because of TP 3 - it actually happened in iTunes. 3.1 didn’t, and probably couldn’t, fix this issue.

    But for the record I usually always upgrade to new Traktor versions and I’ve never had problems. No problems with 3.1 for me.

    IMO Traktor has been the most stable system I’ve used and I’m happy with how they roll out infrequent releases.
     
    • Like Like x 1
  4. Terry Ferg

    Terry Ferg New Member

    Messages:
    21
    Marking this as solved.

    The solution unfortunately is to start over with beatgrids and cuepoints for my entire library :(

    Hopefully I won’t have to redo this again in the future.
     
  5. Bert Patroons

    Bert Patroons NI Product Owner

    Messages:
    38
    I just had the same problem, only not with with AIFF files, but with AAC files.
    I did a lot of testing and it is an iTunes issue.
    Changing a tag (comment and genre are the ones I tried) in the latest versions of iTunes deletes traktor data on some files,
    and even makes traktor give an error message (ID3-tags can not be read")

    I have no idea why some files have this, and some don't.
     
  6. Jayrock79

    Jayrock79 NI Product Owner

    Messages:
    260
    Hi Bert,

    please report it to the ni support.
    There is a massive problem with T3, metadata and aaa-files.
    For years ago there are problems when you directly use the m4a-files, but in T3 there is a really huge bug.
    I'm in contact with the support, but there are not many users who report those problems so they don't force to solve those bugs.
    Thanks.
     
  7. Bert Patroons

    Bert Patroons NI Product Owner

    Messages:
    38

    The only problem is: I ran some more tests, and this problem is 99% sure in iTunes.

    I removed a problematic track (with tags) from the collection completely, copied it 3 times and did this:
    1) If I re-add the track from iTunes: no problem, everything is there.
    2) If I change the comments in iTunes, and then add it to Traktor, the tags are gone. ("ID-3 tag could not be read....")
    3) If I copy the same track over to an older laptop with an older version of iTunes, change some tags there, copy it back and add it to the same version of Traktor, all the tags are there.

    Somewhere along the line, iTunes fucked up. NI can't do anything about that.
    With iTunes being deserted, I don't think anybody will do anything about this. So we can only hope the new music app will not have this problem...

    If anybody can shed some light on this issue, i'm very intereseted.
     
  8. Vinyl Tap

    Vinyl Tap NI Product Owner

    Messages:
    77
    If you change the tags outside of Traktor, the tags won’t be updated in Traktor until you either play the file in Traktor, or run a consistency check...

    This is because Traktor reads those tags from its own Collection, and not from the file itself.
     
  9. Bert Patroons

    Bert Patroons NI Product Owner

    Messages:
    38
    We're talking about Cue-points & Grid being deleted.
    If you change the comments on a track & run consistancy check, the comment field does update. But also the cuepoints are gone.
     
  10. Vinyl Tap

    Vinyl Tap NI Product Owner

    Messages:
    77
    Did you change any of the file names? Because iTunes & Traktor indexes the files on filename & path, and if one changes it can throw the other off.

    I’ll need to check if the Comments tag gets copied to the Collection.nml, because, that might throw the indexing off too. And if the Indexing is off, then the cue points and grid will definitely not be applied (from within the Collection.nml) when you load the track,