1. Hi everyone,

    Apple just released Logic Pro 10.5 for MacOS 10.15. We found out that Massive X, Crush Pack, Mod Pack, Replika, and Replika XT will crash.

    Our teams are currently working on a fix, and we hope to have this out to you as soon as we can!

    Best wishes, 
    The NI Team

    Dismiss Notice

traktor scratch 1.1, crash on startup

Discussion in 'Technical Issues' started by epidemic001, Oct 10, 2007.

Thread Status:
Not open for further replies.
  1. epidemic001

    epidemic001 Forum Member

    Messages:
    106
    Hi everyone, I downloaded the update for Traktor scratch but now whenever I try to open it up it crashes straight away and I get a crashlog file. Has anyone else had this problem or know how I can fix it. I contacted support about this but as yet I've had no reply.
     
  2. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    Hello Epidemic,

    Try uninstalling TS and reinstalling it firstly. If it won't open then it might get a bit trickier.

    Try renaming your Traktor Scratch Settings.xml file to Traktor Scratch Settings.old

    Launch TS and if it starts up, you will have to change your collection settings but it shouldn't happen again.

    Also, please post your ticket number so we can forward it.

    Thanks
     
  3. epidemic001

    epidemic001 Forum Member

    Messages:
    106
    hi!

    I uninstalled and reinstalled traktor again and it was working again, renamed the settings.xml to .old.
    When I installed the update again though it crashed like before.

    My ticket number is 2007100510014908 ( i have just been contacted about this but their suggestions didnt work either)
     
  4. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    Just so I understand clearly...

    You uninstalled and reinstalled, then it was working correct?

    Did it crash again before renaming the XML file?
     
  5. epidemic001

    epidemic001 Forum Member

    Messages:
    106
    yep when I uninstalled and reinstalled it was working.
    So i turned it off, changed the xml file, started it up and it was fine.
    Then installed the update, which installed correctly as far as I could tell, fired up traktor but this time it crashed before anything happend the same as before.

    I also deactivated my internal soundcard but this didnt help either.
     
  6. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    What is the error message you are getting?

    Also, if you haven't already. Delete the update file you have and download it again.
     
  7. epidemic001

    epidemic001 Forum Member

    Messages:
    106
    Yep i already tried downloading the update again.

    The error message says -
    Traktor Scratch1.1.0.090 has encountered a major problem and has been terminated.
    A crashlog file has been created at the following path
    ....(my crashlogs directory)
    please provide this crashlog to the NI technical support.
    thank you for cooperating!
     
  8. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    Could you attach your crashlog here, please.

    What are your system specs also?

    I changed the post title to reflect the issue. The previous title implied it crashed during actual use.
     
  9. epidemic001

    epidemic001 Forum Member

    Messages:
    106
  10. TeLLy

    TeLLy NI Product Owner Extraordinaire

    Messages:
    6,430
    Hey epidemic001, what version of Windows are you running? I know the minimum requirements state 512MB of RAM but perhaps you need an upgrade; if you're running Vista I REALLy recommend upping it to at least 1GB.

    Did you install Traktor using your default/admin profile on the laptop? One other thing you could try is creating a separate profile in Windows specifically for Traktor, disable all the unnecessary services (ie wireless, print spooler, etc), and installing TS and the update from within that profile.
     
  11. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    What is weird is he can run 1.0, only 1.1 crashes on startup.

    The application should at least run, if he has performance issues that's a whole other subject.

    Something is very funky here.

    Try killing all other unnecessary programs that might be running and run TS by itself.

    Another thing you could try doing is running TS in safemode to see if it still crashes. Then we could narrow it down to some type of conflict.
     
  12. epidemic001

    epidemic001 Forum Member

    Messages:
    106
    I'm running windows xp.
    I will try all of your suggestions when I get home from work.

    thanks guys
     
  13. DJ Freshfluke

    DJ Freshfluke Traktor Mod Moderator

    Messages:
    26,779
    definitely a support case... please stay in contact with them!
     
  14. epidemic001

    epidemic001 Forum Member

    Messages:
    106
    its working now!
    The problem seems to have been that I had an audio cd in the cd drive which for some reason caused it to crash when starting up.
    Once the cd was removed traktor started up correctly. I put the cd back in again and tried trakor and it crashed again. So its deffinately that causing it.
    Its abit strange that this only happens with 1.1 though.

    Thanks for everyones help and suggestions!:cool:

    john
     
  15. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    Goodness!

    Definitely file a bug report for that!

    That is not normal behaviour, but at least you can use 1.1 now.

    Does this happen with all Audio CD's?
     
  16. epidemic001

    epidemic001 Forum Member

    Messages:
    106
    yep I tried a different cd and it did the same.
    Although I also tried it with a blank cd and traktor worked
     
  17. TeLLy

    TeLLy NI Product Owner Extraordinaire

    Messages:
    6,430
    Was the CD drive reading the CD in any way, ie retrieving track info from the internet, playing in Windows Media Player, etc? Was the autoplay prompt up on your screen? Just curious at this point.
     
  18. epidemic001

    epidemic001 Forum Member

    Messages:
    106
    nope the CD wasnt being used in any way as far as I could tell, there's a chance that there might be something using it in the background which I'm not aware of but I doubt it.

    By the way I'm loving the 1.1 update! it was worth it :D
     
  19. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    Do you have the autorun feature enabled for your CD drive?
     
  20. epidemic001

    epidemic001 Forum Member

    Messages:
    106
    i think I might do, whenever I put a cd in I get pop up asking me what I want to do with the disk i.e. browse it, play in media player etc
    I'm guessing that could be the autorun feature.
     
Thread Status:
Not open for further replies.