SELECT A PERCUSSION VERSION

System Requirements: FREE KONTAKT PLAYER or KONTAKT (version 5.6.8 or higher)
Please also see the KONTAKT PLAYER system requirements and the KONTAKT PLAYER FAQ - Intel i5 processor recommended.
An Internet connection and a graphics card that supports OpenGL 2.1 or higher are required to download and activate this product. Once installed and activated, the product can be used offline. Please also see the Native Access system requirements.


Description